Dead headlamps - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 16-12-05 Thread Starter
Status: -
AO Member
Join Date: Jul 2003
Location: London
Posts: 13
Hmmm Dead headlamps

My headlamps have gone a bit strange today - the side lights work, and the headlamps work on full beam, but neither headlamp comes on when they are in the dipped setting. Can anyone tell me why/whether it will be difficult to fix by any chance? Thank you, lilyx
lilypicadilly is offline  
Sponsored Links
Status: -
AO Member
earthman's Avatar
Join Date: Aug 2003
Location: london
Posts: 629
Re: Dead headlamps

check fuses 7 (RH bulb) & 8 (LH bulb) it would be a bit strange if they have both blown but you never know.
maybe one of your bulbs had blown a while ago and now the other one has gone, now it's more noticable that you have none?
the dipped beam is a bulb all on it's own, not all car shops seem to stock these, and they are not that cheap.
if fuses & bulbs are ok then it could be relay/wiring/switch or bad connectors/earth problem.
let us know what you find.
earthman is offline  
(Post Link) post #3 of 3 Old 19-12-05 Thread Starter
Status: -
AO Member
Join Date: Jul 2003
Location: London
Posts: 13
Re: Dead headlamps

Both bulbs gone, rather strangely.
But all fixed now. Thanks very much for your help.
lilypicadilly is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

dead , headlamps

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome