spider injector - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 04-07-13 Thread Starter
Status: alfie has now gone we miss him....
AO Member
alfyandmay's Avatar
Join Date: Sep 2009
Location: United Kingdom
County: Staffordshire
Posts: 345
Images: 29
spider injector

Hi there,

We have just had our spider 2 litre JTS M.O.Ted.

It needed a new front pipe on the exhaust which we knew about which has the lambda sensor fitted in to it.....

Yesterday on the way home the car stalled in mid flow and came to a grinding halt.

Restared the car no problem but the engine management was on.

Restarted the car 3 times and the light went off and drove home no problem.

My Mrs drove to work the other morning and the same thing happened...car stalled,light came on but car restarted normally.

I thought the garage had bust the lambda sensor so the Mrs booked it in at the same place but on there diagnostic it said it was in injector but not sure what for definate until tomorrow......

Car drives great,revs freely,doesnt smell of fuel...surely if it was an injector there m,ay be rough idle or some other symptom and not just stall out of the blue.....

Drove it home today after work and picking up from garage and everything was fine....

Anyone got any ideas


Mark g

alfyandmay is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

injector , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome