Slow start on a warm day??? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 02-07-13 Thread Starter
Status: -
AO Member
taylorj1985's Avatar
Join Date: May 2012
Location: United Kingdom
County: Bedfordshire
Posts: 21
Slow start on a warm day???

Hello all,
Been having some issues over the last few weeks with my 3.0 gtv, the main one being that when the outside air temp gets warm (15 degrees and above usually) my car is really hesitant to start. It will always fire eventually but I'm sometimes turning it over for 3-4 seconds before that happens. I suspect the maf sensor but just wanted to ask around for some opinions before I fork out.
Thanks in advance.
taylorj1985 is offline  
Sponsored Links
Status: Planning summer upgrades
AO Member
AussieAlex's Avatar
Join Date: Feb 2013
Location: Aussie in Sweden
County: Stockholm
Posts: 742
Images: 12
I would try giving the MAF sensor a clean out or even a simple re-fitting to ensure its secured properly?

But it is sad that you poms think 15*c is hot xD Its 17*c here in the middle of winter and I'm freeeeezing :P
AussieAlex is offline  
Status: mellow yellow
AO Member
Join Date: Jan 2010
Location: Spain
County: Santa Cruz de Tenerife
Posts: 165
Images: 6
I agree, clean the MAF,42c outside at the moment,mine starts ok....
yellowspyder is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

day , slow , start , warm

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome