Problems after fitting Koni, Q2 and Alfaholics kit - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 14-06-13 Thread Starter
Status: -
AO Member
Øyvind I's Avatar
Join Date: Mar 2010
Location: Norway
County: Akershus
Posts: 31
Problems after fitting Koni, Q2 and Alfaholics kit

Hi, I´ve just collected my 01 GTV 3.0 from my local dealer after having fitted:
Alfaholic sway bars (great!)
Yellow Koni front shocks
Original rear shocks
Q2 + Lightened flywheel + GTA Clutch.

Springs are standard after removing Eibach and before that H&R. All these 3 springs combined with Bilstein B6. Before modification the car had original springs and the Bilstein shocks.

The front is now about 2 cm lower from the looks and there are almost no suspension travel (again, original springs and Koni so it should not be lower than with Bilstein) before bottoming the front end. Even going 20 km/h over sleeping policemen / rounded speed bumps causes slightly strange sounds from the front and bottoming.
Doing 40 km/h in 2nd gear there are no sound but when having 4th gear noises from the front are heard, quite high mechanical noises.
Engine warning light (yellow) also blinked after 20 km, now constant on. Suspect cleaning of engine.

Any ideas what could be wrong here? Garage is not to experienced with modifications as above but is generally good for standard cars. Less than 7 GTV 3.0 here in Norway.

Except from horrors above the impression with the sway bars combined with Q2 is great. Will add more info on this marvelous modification later.

Regards Øyvind

Last edited by Øyvind I; 14-06-13 at 22:43. Reason: Clarifying
Øyvind I is offline  
Sponsored Links
Status: -
AO Member
Join Date: Oct 2012
Location: United Kingdom
County: Bedfordshire
Posts: 175

Member car:

GTV 3.0 V6

New springs needed?

You might need new springs too, by now...

Mine were sagging.

So now I have OEM-height Suplex springs with Yellow Koni Sports up front and OE dampers at the rear and have no problems.

I wanted a normal ride height with better handling and now I have it!

I do feel like I might need to put some Koni or Bilstein dampers on the rear, though...
aliasmonkey is offline  
Status: Selespeed that's reliable
AO Gold Member
turbonutters's Avatar
Join Date: May 2009
Location: South Africa
County: Gauteng
Posts: 7,035

Member car:

GTV 2.8 Turbo

koni on rear transformed my GTV
turbonutters is offline  
(Post Link) post #4 of 4 Old 17-06-13 Thread Starter
Status: -
AO Member
Øyvind I's Avatar
Join Date: Mar 2010
Location: Norway
County: Akershus
Posts: 31
Just ordered new front springs from Alfaholics. The ones thats on the car have just done 10.000 km (Spidan is the manufacturer).
Will have these fitted next week.
Now the front wheels are toutching the inner wing going more than sleeping speed.
The rear comes next.
Øyvind I is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

alfaholics , fitting , kit , koni , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome