2000 Alfa Spider Throttle Cable Replacement - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 02-05-13 Thread Starter
Status: -
confusion's Avatar
Join Date: Feb 2013
Location: Australia
County: Western Australia
Posts: 2
2000 Alfa Spider Throttle Cable Replacement

Hi Ya'll. I'm a Yank living in Perth Australia. This is my first post. My car is a white 2.0 TS 5spd. It has 90,000k. It's my first Alfa. I was hesitant to buy it,having heard of reliability issues with them in the past. Anyhoo, Since January,both window regulators have broken. I've ordered replacements. Now the throttle cable has snapped. I've read most of the posts regarding this repair. Mine seems a bit different. I jacked up both sides of the vehicle and put it on jack stands. I've lowered the engine by releasing the top right mount and bottom brace in front of the right wheel. This gave me the clearance to access the nut and plastic thing that goes into the fire wall. I took off the plastic piece and grommet it plugs into. There is still something holding the cable inside the fire wall. It looks like another rubber piece. Looks like I am going to have to work from inside the car now. I will let you know how it goes. Any help will be great. Thanks
Attached Images
File Type: jpg 20130502_140916.jpg (57.2 KB, 15 views)

Last edited by confusion; 02-05-13 at 06:31. Reason: Add Photo
confusion is offline  
Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,069
Can't really tell from your picture, but the swivel on the bulkhead should be a double one - one for the bonnet cable and one for the throttle cable, IIRC. The cable end should just slot in to the swivel, although access is awkward. I should point out this is from memory - its a while since I stripped a GTV.
rgwm is offline  
Status: Have another Alfa
AO Gold Member
wayne-dear's Avatar
Join Date: Apr 2008
Location: United Kingdom
County: Merseyside
Posts: 10,132
.....I got the cables out without moving the engine...

If I remember there is a rubber grommet in the bulkhead, sure with a bit of effort it pushes through..

Welcome to AO
wayne-dear is offline  
(Post Link) post #4 of 4 Old 03-05-13 Thread Starter
Status: -
confusion's Avatar
Join Date: Feb 2013
Location: Australia
County: Western Australia
Posts: 2

Thanks for the help. Yes, there is another hole below with a black plastic swivel that releases the bonnet. So far, I've removed the white plastic end of the throttle cable, a black rubber grommet, and another black small rubber cone from that hole in the photo. There still appears to be some sort of black plastic thing in the hole that I can see when I pull on the cable. What concerns me is that I don't know what the cable is attached to, nor how it is attached. I don't want to break anything by just yanking hard on it. I haven't had much time to fiddle with it. Maybe it's just a matter of twisting and prodding and it will be obvious how to put the new one in when I get the old cable out,but, I can't see in the hole to know what I am up against. And I don't know what the end of the cable looks like,because I cant find a replacement and have to have a cable made.
confusion is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

2000 , alfa , cable , replacement , spider , throttle

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome