Chipmunks in the exhaust! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-04-13 Thread Starter
Status: Loving the Gtv.
AO Member
NedFlanders's Avatar
Join Date: Nov 2012
Location: Ireland
County: Cork
Posts: 169
Images: 2
Chipmunks in the exhaust!

Ok - maybe not, but as I start to move off or go over a speed bump slowly, there are sounds from underneath that to me sounds like a group of chipmunks chuckling.......

Considering that I doubt there's a family of rodents underneath and the mechanic greased something to do with exhaust mounts to stop the noise at the service - what do I need to replace or do and how any are there please?

I'm presuming its the various exhaust rubber mounts like this:

Powerflex Red Exhaust Rubber's - Autolusso New Alfa Romeo Parts

Am I anywhere near the problem or will I have to jack it up and wobble the various bits around to get to the bottom of it?


NedFlanders is offline  
Sponsored Links
Status: -
AO Silver Member
jonnogtv's Avatar
Join Date: May 2010
Location: United Kingdom
County: Antrim
Posts: 1,237
Images: 4

Member car:


Could be the heat shield, they rot and break away from the screws.

Easily fixed with a large washer.
jonnogtv is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

chipmunks , exhaust

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome