Have i got the correct engine mount ? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 08-04-13 Thread Starter
Status: Polished Up
Club Member
Membro Premio
Morris260309's Avatar
Club Member Number: 1605
Join Date: Nov 2009
Location: United Kingdom
County: West Yorkshire
Posts: 3,714
Have i got the correct engine mount ?

As the title can someone please confirm if its correct or not
Cheers Simon
Attached Images
File Type: jpg uploadfromtaptalk1365436272780.jpg (43.2 KB, 19 views)
Morris260309 is offline  
Sponsored Links
Status: -
AO Silver Member
AnthonyJohn's Avatar
Join Date: Apr 2010
Location: United Kingdom
County: Dorset
Posts: 2,029
Images: 4
Looks like the right mount but check it's on the right way round as sometimes the orientation is incorrect. This was the case with my Cup when I bought it but corrected now.
AnthonyJohn is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

correct , engine , mount

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome