hazards and indicator problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-03-13 Thread Starter
Status: -
AO Member
Join Date: Dec 2010
Location: United Kingdom
County: Durham
Posts: 18
hazards and indicator problem


Can anyone suggest why,when I use my indicators, either right or left, the indicators on both sides flash as if I have switched on my hazard warning lights.
fulthorpe is offline  
Sponsored Links
Status: -
AO Member
Join Date: Feb 2012
Location: United Kingdom
County: -
Posts: 108

Member car:

P3 GTV 2.0 JTS

I've just had months of trouble with my flashers and indicators leading to my changing the relay only to find out that it was the rear window heater that was the rot of the problem by shorting other things out.

In your case it sounds like the relay, I have my old, and presumably still fine, relay. This means I'm over stocked with relays to the tune of one. Find out if yours is compatible with a 2005 JTS part no 60570359, I suspect it is, if so PM me your address and I'll post it off to you.
Oldrover is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

hazards , indicator , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome