Slow rad fan relay - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Slow rad fan relay

hi guys found the fast speed relay under dash on the left of three next to front fog light relay wheres the slow speed one please guys?
Sponsored Links
Status: Missing the Busso noise!
AO Member
ICEMANV6's Avatar
Join Date: Nov 2009
Location: United Kingdom
County: Hampshire
Posts: 437
I could be wrong but is it not on the back of the radiator fan housing on the top left as you look at it from the front.
ICEMANV6 is offline  
Status: - Update
Posts: n/a
Hello thought i would send you an update on the fan scenario.
I put a piece of wire onto the relay terminal that is triggered by the ecu to set the first speed fans and touched the other end to earth and hey presto they work so its either the wire from ecu to relay or the ecu me thinks.
So ecu swap at the weekend me thinks
Would i be correct in assuming that the thermocouple works as the fast speed was getting tripped by the ecu im guessing the ecu is just not dishing out the slow speed signal.
Status: -
AO Member
nu_groove's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: West Sussex
Posts: 137
Images: 7

Member car:

GTV 2.0 jts (P3)

Looking forward to hearing how you get on with this - got similar issues with mine
nu_groove is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

fan , rad , relay , slow

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome