my wipers have stopped working?? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 10-02-13 Thread Starter
Status: Lack of sleep with new born baby
AO Silver Member
Join Date: Jun 2010
Location: United Kingdom
County: Staffordshire
Posts: 2,646
Images: 3
my wipers have stopped working??

hi guys my wipers have stopped working tonight on the way back from the petrol station. it started to rain so i put the wipers on and then they stopped working on all speeds? i couldnt see so i tried the washer wiper and pulled the stalk back and the wipers worked all the way home pressing the stalk. I then turned the engine off and checked the fuses under drivers footwell and all good turned the engine back on and now the wipers dont work at all.

any ideas, what should i check next?
jonalfaspider is offline  
Sponsored Links
Status: Please look after this possum
Regional Support North
Is there a meet near you?
Gaz's Avatar
Join Date: Jun 2008
Location: Behind the wheel
County: Lancashire
Posts: 62,404
Gaz is offline  
Status: - Update
Posts: n/a
Sounds like connectivity at the stalk?
Status: Planning the next project ...
AO Silver Member
Join Date: May 2007
Location: United Kingdom
County: Bedfordshire
Posts: 3,953
I'd be inclined to check the N14 device first. It's a control box near the fuse box.

If you do a search on 'N14' you'll find a lot of information on how it goes wrong and how to find it.

e.g. a good post on finding it here :
pkr is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

stopped , wipers , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome