Engine Vibration - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 28-10-12 Thread Starter
Status: Still on the roundabout!
AO Member
Bryan the snail's Avatar
Join Date: Feb 2010
Location: United Kingdom
County: Northumberland
Posts: 145
Engine Vibration

Is it possible for the balance shaft to slip?

I gave my 2.0 ts a bit of a thrashing last night and now the engine is vibrating when revved above 2,500 rpm. The exhaust note has also changed, it used to have a nice rasp above 3,000 rpm, now it just sounds flat.
The belts and tensioners where all changed about 6,000mls ago, so I don't think the cam belt has jumped. The engine still revs to the red line but doesn't seem as responsive, also revs don't seem to drop down as quickly when you lift off and dip clutch.
I have just cleaned the air filter and checked the inlett for leaks, the exhaust doesn't appear to be blowing anywhere.
Bryan the snail is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

engine , vibration

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome