Spark plugs - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Spark plugs

Was about to change my plugs,got to the 4th lead and couldnt pull or twist it out!
Unbelievable how the first 3 pull out fine and its the last that beats me.

No joke,it was as if it was welded onto the coil pack rail!

Any advice please!
Sponsored Links
Status: Planning the next project ...
AO Silver Member
Join Date: May 2007
Location: United Kingdom
County: Bedfordshire
Posts: 3,953
Why didn't you just unscrew the rail from the cam cover ( 3x 5mm allen bolts ) and remove the rail and coil packs in one assembly?
pkr is offline  
Status: Spinning like a cat
AO Member
redtop_68's Avatar
Join Date: Sep 2011
Location: Sweden
County: Stockholm
Posts: 515

Member car:


Could be the rubber sealing that is seized to the spark plug well. Try some silicon spray down the well.
I had similar problems first time I removed the plugs on my car. When I finally got everything off I put some silicon grease on all the sealings as an investment for the future...
redtop_68 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

plugs , spark

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome