My 2002 GTV Phase II 3.0 sound like a subaru - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 22-09-12 Thread Starter
Status: -
Join Date: Apr 2006
Location: Cape Town South africa
Posts: 3
Images: 2

Member car:

2002 3.0 gtv

My 2002 GTV Phase II 3.0 sound like a subaru

a very well maintained and a sweet ride..up until a two weeks ago. it started with a strange vibration,ever so slight, at above 4K rpm and under load.I know this motor very well so knew something was not right. (slightly down on power). This was also intermittent. Then the the car started to idle a lumpy.. also intermittently. and then...oh horror ! it would not rev ,sounded like a subaru. (no misfire sounds more like fuel starvation to me) put foot flat ,lights up like a scalded cat at 4K rpm plus. Motor will rev and pick up as normal under zero load. Another interesting thing is when you first start the car it runs normally for about 5 mins (hot or cold) So... checked all the wiring.checked all the relays,checked the plugs (brand new items) checked the coil-packs, checked all the pipe work, the induction system is as clean as a whistle.Had an Autodelta high-volume air-filter in the car for 18 months now. Throttle-body was spotless,even had a look at the throttle body actuator mechanicals clean and operational. Put the care on diagnostics..traced on fault (code key..this has in the past prevented me from starting the car but cleared itself a while back.0 this was reset. No other fault shown..I do know that a faulty MAF does not always show up as a fault. Decide to buy a MAF (Bosch). Ran all the usual reset procedures (throttle and ECU) The car is still exactly the same. Start it and it will run very well for 5 minutes and then sound like a subaru (sound like running on three < firing on all six tho>).
Before i go the lamda route i would love to hear from any member who has a possible solution. I have spend 600 pounds already and still have a pristine well maintained 60k car that does not go....
arturo is offline  
Sponsored Links
Status: I'm the guy driving the red Italian convertible
AO Member
IanA's Avatar
Join Date: Oct 2010
Location: United Kingdom
County: Oxfordshire
Posts: 166

Member car:

Spider 916

The easiest way I know of making a V6 sound like a rorty V8 is to take a plug lead off. When it is misbehaving, see which exhaust manifold pipe is the cooler one. Use a piece of wet rag or ideally a non contact IR thermometer. Then it's down to substitution of plug, lead, coil pack, etc. to see which one the problem moves with. Sounds like an intermittent ignition something.
Good luck.
IanA is offline  
Status: -
AO Silver Member
.:ian:.'s Avatar
Join Date: Feb 2009
Location: United Kingdom
County: Hampshire
Posts: 1,574

Member car:

GTV twinspark

That does sound like a lambda, especially as it only does it when warm and at low revs. It should flag errors though, what diagnostics were used?

You most likely have 4 lambdas so you really need a hint at which one you need to replace.
.:ian:. is offline  
Status: -
AO Silver Member
Alfafamily's Avatar
Join Date: May 2010
Location: United Kingdom
County: Warwickshire
Posts: 5,758
Images: 10
My son's car ran like that after it had had new front pipes fitted. The lambda connections had been mixed up.
Alfafamily is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

2002 , gtv , maf or lambda , misfire or hesitation , phase , reset , sound , subaru

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome