Warning Lights and ECU problem Help!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 05-09-12 Thread Starter
Status: -
Join Date: Feb 2012
Location: United Kingdom
County: Cardiff
Posts: 8

Member car:

GTV 3.0 V6

Warning Lights and ECU problem Help!!

Hi Guys

I've got a bit of an issue with my 1999 GTV (3.0 v6)

The speedo has stopped working intermittently. I find it's usually fine first thing in the morning but after a couple of miles it stops working (drops back to zero) PLUS my ABS and Handbrake light come on as this happens. There seems no issue with the breaks/pads etc. Took it to my usual garage who plugged into the ECU but they tell me they cannot communicate with it??

While we're on it my fan comes on for no reason intermittently too, even when the engine is cold.

Finally my central locking has also stopped working, although this may not be related..........any idea's or do I need a new ECU?????

Any help would be greatly appreciated as the MOT is due on Friday!!
MartyCoggs is offline  
Sponsored Links
Status: - Update
Posts: n/a
With the central locking, if you unlock the door manually (with key) then sit inside and push lock pins on both doors
(drivers side and passenger side) and then try locking and unlocking car with key fob.

I had the same problem today and it worked.
Status: And on the eighth day God made Alfas..!
AO Gold Member
pendragonfalls's Avatar
Join Date: Feb 2010
Location: Ireland
County: Carlow
Posts: 6,590
Images: 20
If your aircon is on, the fan will cut in and out even when the engine is cold. Mine does it as well.. :mygrin1:
pendragonfalls is offline  
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,613
Your speedo is driven by the ABS module, which takes readings from each wheel speed sensor. Its likely your ABS module is dead - its a fairly common problem on P2 GTVs. When you say the garage couldn't connect to the ECU, do you mean the engine ECU or the ABS ECU?
Pud237 is offline  
Status: doing very little with my left foot these days
AO Member
ML Spider's Avatar
Join Date: May 2011
Location: Warwick
County: West Midlands
Posts: 229
Take a look at my Winter Strikes... The Speedo thread http://www.alfaowner.com/Forum/alfa-...he-speedo.html someone came up with the exact answer for my problem, perhaps it will help you. Two minutes work and the problem has gone for good.
ML Spider is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

ecu , lights , problem , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome