Spider hood cover release motor fix - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 28-08-12 Thread Starter
Status: Cup-A-Likes are nice too
Identity Confirmed
Authorised Trader
CGTVs's Avatar
Join Date: May 2012
Location: United Kingdom
County: West Sussex
Posts: 2,445
Wave Spider hood cover release motor fix

Spider hood cover not releasing or locking? Well it's not necessarily the cog so before you order one open the motor to check.

I've just done this & found an as new cog.

So after trying to get the motor to stop in another position, too difficult to be 100% sure without marking, & trying with a direct feed from a battery....it still was intermittent after half a dozen attempts.

I decided to remove the motor body by unscrewing the 2 screws & carefully withdrawing it complete with worm drive, make sure you don't loose the spherical bush & small black cog + sprung washer from the end. Removed the gasket & sprayed the contacts with contact cleaner(not WD40), put it all back together & after a dozen+ operations all's well.........so far.

Originally posted in:


Useful exploded picture in:


CGTVs is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

cover , fix , hood , motor , release , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome