Sorry, another overheating thread (2.0TS) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 23-08-12 Thread Starter
Status: The Alfatographer
AO Member
ALXege's Avatar
Join Date: Jan 2007
Location: Romania
County: Bucuresti
Posts: 290
Images: 46

Member car:

939 Spider

Sorry, another overheating thread (2.0TS)

Sorry for creating new thread, remember reading lots of similar threads but can't seem to find a more generic one to post my issue in.

So.. '99 Spider 2.0 TS CF2.
Recently replaced thermostat, temperature sensor and finally, new radiator.
While driving into town in the middle of the day (at temperatures of 40+Celsius), with Air Con off, the engine temp fluctuates around 100 (the fans kick in, temp goes down, then goes back up, then fans kick in again and so on). But if I turn Air Con on, it goes to 110 and never seem to go down.
Both fan speeds work just fine. Water pump replaced last spring, when doing the cambelt job.
Have no ideea what to do next

An amateur, non-commercial POV: | Alfatographie on Facebook
ALXege is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

20ts , overheating , thread

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome