complete power loss and back firing... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 16-08-12 Thread Starter
Status: -
Join Date: May 2012
Location: Belgium
County: Vlaams Brabant
Posts: 1

Member car:

Spider 916

complete power loss and back firing...

I always found that the Spider was one of the best looking cars ever made and I finally got one 2 months ago (1995, phase 1 model). Unfortunately, Iím not enjoying it as much as expected, since the car has the annoying habit of dropping power when drivingÖStarting is never an issue, but while driving, the power can suddenly drop completely (injector light also switch on). When pressing the throttle, the exhaust will backfire. The only way to continue is to switch off the ignition and start the car again, and the power will come back immediately. Since you never know when it will happen, it does take away the fun, as you donít want to lose power when overtaking, for exampleÖ
I when to the local Alfa garage twice already, they have replaced the Ďair mass meterí but that didnít solve the problem. The second time, they told me that it was probably a problem with the ignition unit, but replacing this would be very expensive (+ 1000£) and extremely hard to find the partsÖ
Since i donít want to get rid of the car just yet, does anyone have some ideas?
bart.porta is offline  
Sponsored Links
Status: -
AO Silver Member
euroboy's Avatar
Join Date: Sep 2006
Location: Netherlands
County: -
Posts: 2,877
Images: 52
Download a copy of FiatEcuScan and buy a VAGCOM cable from eBay - read the codes yourself and take it from there.

Otherwise you will end up throwing good money after bad at it, and may never find the cause.

There is something you can do for free - check the sparkplug wells are not full of water. Many a mis-firing twinny has been down to that before
euroboy is offline  
Status: AROC 916 Registrar
AO Gold Member
Mitch916's Avatar
Join Date: Nov 2002
Location: United Kingdom
County: Kent
Posts: 8,803
Images: 8

No point random guessing, as the light has come on, the fault code will be logged. Best get it read.

I have done a write up for this on the Ph 1. I just haven't had time to post it yet!
Mitch916 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

back , complete , firing , loss , power

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome