ABS light illuminates over 60 mph - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 05-07-12 Thread Starter
Status: Farewell and thanks GTV.
AO Member
Junior's Avatar
Join Date: Feb 2003
Location: London
Posts: 691
ABS light illuminates over 60 mph

Hi all,

On my way to the Festival of Speed, the ABS light flashed on as I was joining the motorway. It stays on until I switch off the ignition and the light doesn't illuminate until the car is travelling over 60 mph. I did have a rear wheel bearing replaced in May and this is the first time since then that I have driven at motorway speeds, so I don't know if it is related to that repair or if it is just a coincidence. Does this sound like a faulty sensor, or could it be a problem with the ABS pump itself?

I expect that I will have to take it to a garage for them to plug in the diagnostics and read what fault code comes up, but I would like to have an idea of what sort of repair costs I am going to face.
Junior is offline  
Sponsored Links
Status: -
AO Member
Join Date: Nov 2002
Location: Glasgow, UK
Posts: 19
Yep, sounds like a faulty sensor.

I had this a couple of years ago. Garage had the car for two days attempting to diagnose as they were adamant that there was nothing wrong with the abs sensor/wheel bearing they had fitted.

Said they took it for a spin with the diag tool connected and readings 4 wheels were the same, but as soon as they hit 60ish on came the light. After finding nothing else wrong they eventually gave in and swapped the wheel bearing. Problem disappeared.
Phwed is offline  
(Post Link) post #3 of 4 Old 07-07-12 Thread Starter
Status: Farewell and thanks GTV.
AO Member
Junior's Avatar
Join Date: Feb 2003
Location: London
Posts: 691
Thanks for your reply. I suspected that it might have something to do with the new bearing fitted. I can foresee an uphill battle with the garage claiming that there is nothing wrong with what they fitted. I hope I am wrong.
Junior is offline  
Status: Ex GTV owner
AO Member
Alexzver's Avatar
Join Date: Feb 2009
Location: Slovenia
County: -
Posts: 760

Member car:

GTV, 145, 147

I paid 160€ (incl. labour) for a new rear ABS sensor last year for my 97 GTV.
Alexzver is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

abs , illuminates , light , mph

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome