PH1 Spider radiator fan - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 26-05-12 Thread Starter
Status: Immobilised ;-(
spidergeek's Avatar
Join Date: Feb 2012
Location: United Kingdom
County: Greater London
Posts: 7
Images: 2

Member car:

Spider 916

PH1 Spider radiator fan

So, once again the radiator fan decides to switch on and stay on (full power) even with the ignition key removed etc. Disconnect the fan as you park becomes the new way of getting around, or for motorway cruising, don't bother with the fan at all. Not really a good plan.

I dug out the wiring details for this (my car is an early PH1 with aircon) and located the delightful "Q41" lash up under the o/s wing plastic cover. Relay L100 does the full speed stuff, and L99b the slower speed. Popped them both out, reconnected my radiator fan and now it's stopped running all the time.

Start the car up and let it warm up. The fan kicks in as expected. Didn't leave it to go superspeed as it rarely does. I'll need another long queue on a blistering hot day in traffic to trigger that.

But the point of this post is that while I appear to have solved my problem I don't believe I have. I'm almost 100% confident that that next super hot engine event will do this all over again. My temp gauge rarely goes above 90, ie central but in queued traffic will eventually go up towards the next mark and kick in full speed on the radiator fan, which with the hood down in this fab weather is easy to hear! This then won't stop until I remove (and replace) the relays and/or unplug the fan. Reconnect the fan, even hours later with no key and it runs. Remove the relays and replace, reconnect the fan and it's fine. So the system resets when I remove L100, but not until.

So my question is, what's holding the relay (L100 in this case I believe) "on" because until I remove it the fan spins. This is where the workshop manual (55-26) seems to get a bit vague (@ p318 in Part 3 on mine if anyone's interested!). It describes Q42 as the "cooling fan delaying device" - or white box in reality which since I cannot see what it is I don't want to open up and break!!!

Seems the rad pressure switch triggers the first speed via L99b and sets the timer on Q42. If the pressure switch signal persists past the delay period (is this really 8-12s - seems pretty short to me?) then L100 gets a kick to fire up "turbo" mode on the fan.

Anyone else figured this out? It all seems fairly "Italian" !!!

What does this delay device consist of, and can I establish what it is - bet it's a stock Fiat parts bin item if one but knew what to ask for??? Mine is white on white now, and indecipherable. Anyone got one they can read a part number from?

thanks all
- John
spidergeek is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

fan , ph1 , radiator , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome