Changing battery has caused alarm issues! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Help Changing battery has caused alarm issues!

I have a GTV and, after returning from a business trip discovered that a period of her standing had drained down the battery.

As I tried to turn her over the alarm set itself i.e. hazards flashing and siren sounding.

I purchased a new battery yesterday and switched alarm off with isolation key to save my eardrums when fitting it.

The problem is I cannot turn the alarm back on because it constantly goes off. The strange thing is even with the alarm disabled, the hazards keep flashing for a period of twenty to thirty seconds if I start the engine up or open a door!

Can anyone help me please?
Sponsored Links
Status: -
AO Member
earthman's Avatar
Join Date: Aug 2003
Location: london
Posts: 629
Re: Changing battery has caused alarm issues!

Dave maybe it would help if you told us what type of alarm is fitted to your car, is it the type that has the remote built into the key or is it like mine, where the remote is a black square fob ?
earthman is offline  
Status: - Update
Posts: n/a
Re: Changing battery has caused alarm issues!

Have you got the META alarm?

I'm guessing.....sounds like the alarm and doors have got out of sync. Just had this with the Spider......the doors are unlocked but the alarm isn't off so it goes off when you try and start the car.

Make sure when you're in the car that the alarm is off before starting. If this fails then the fob is not being recognised by the receiver...a common 155 problem but I suspect not the same for yours

Over to someone else......

Status: ready4vacations
AO Platinum Member
Join Date: Jul 2002
Location: Portugal
County: Porto
Posts: 31,304

Member car:

Alfa 159 QV

Re: Changing battery has caused alarm issues!

Hi Dave, welcome to

I can sugest you one thing: clean the alarm memory by using the master key and not the remote.
THROTTLEMAN is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

alarm , battery , caused , changing , issues

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome