New GTV owner - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 26-03-12 Thread Starter
Status: -
AO Member
Join Date: Mar 2012
Location: United Kingdom
County: Greater London
Posts: 263
Images: 10

Member car:

156GTA 147SS

New GTV owner

Hi all. Am a new owner of a 99 3.0 GTV Lusso, also having a 156 in my fold. I purchased the car a couple of weeks ago, for not very much at all, and there are a couple of issues I need to resolve within the next few weeks so would appreciate any help that you may be able to offer. And I look forward to filling my head with all the helpful GTV info on this site.

1. ABS break light comes in intermittently. I will check the sensors are in order.
2. Injector light somes on with the loss of power upto around 2k rpm. I will check the cables leading upto the throttle and connect/disconnect to see if that makes a difference.
3. There is a lot of oil under the arch on the driver's side wheel. I have not yet had the opportunity to look under the car in detail but was wondering if there could be an indication of the likely causes.

I have read some information about the causes/solutions to 1 and 2 above but will post more after I've had a look under the car in the coming few weeks. For now the car is grounded until I resolve all these problems. Any input would be appreciated and I also thought what better way to introduce myself to the fold.
GTV_Slave is online now  
Sponsored Links
Status: The rebuild has begun!
AO Member
Preston916's Avatar
Join Date: Jan 2012
Location: United Kingdom
County: Glasgow
Posts: 255
Images: 4

Member car:

916 Spider & GTV

I'd say that the loss of power and the injector light are likely to be the MAF sensor needing cleaned or renewed.
Preston916 is offline  
Status: Deleted
AO Gold Member
jillyflower's Avatar
Join Date: Jul 2006
Location: United Kingdom
County: Peterborough, Cambs
Posts: 10,976
Images: 8
Hi GTVslave. Nice car you've got yourself there Good luck getting her back in top condition and Welcome to AO
jillyflower is offline  
Status: -
AO Member
k-ro's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: Derbyshire
Posts: 515
oil cooler is driver side i think?? Likely culprit
k-ro is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

gtv , owner

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome