GTV cutting out intermittently - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 11-01-12 Thread Starter
Status: -
AO Member
Join Date: Jan 2011
Location: Ireland
County: Dublin
Posts: 337

Member car:

2.0 TS GTV

GTV cutting out intermittently


Fairly quick one I hope for you.

Got into the car this morning to get into work EARLY, went to the petrol station, filled to halfway and it cut out four times before I could restart. Cut out again getting out of the petrol station when I slowed, then cut out at two roundabouts, loss of power then boom cut out.

I did hear some sort of bizarre noise before this started, first time it cut out all the dash lights came on and the fuel gauge blinked like a nutter, all the other times, it cut out the dash lights came on for oil, battery and something else I can't remember (the fuel injector and airbag light are always on)

Drove home and got the Oh to give me a lift in his car. From reading on here sounds like crank sensor issue? Happened once before over Christmas, the car has a new battery since beginning Dec. the terminals were checked then and are fine.

Thoughts on crank sensor failure or pending failure?

Just to add to the list of work I've to do the timing kit is due and scheduled for the next ten days so while a piece of work like that is being done if I can deal with stuff like this it will be good
nouggatti is offline  
Sponsored Links
Status: -
AO Silver Member
00Alfa Andy's Avatar
Join Date: Aug 2010
Location: United Kingdom
County: Kent
Posts: 4,300
Images: 45

Member car:


Originally Posted by nouggatti View Post
Thoughts on crank sensor failure or pending failure?
Hi, I have a similar problem!
Try this.. start the car and let it tick over, if it reaches around the 65c mark and cuts out, its probably what I'm experiencing and my thoughts are crank sensor.
Not easy to get to but cheap to fix (if your handy with a set of tools)
00Alfa Andy is offline  
Status: -
AO Member
javars's Avatar
Join Date: Nov 2006
Location: United Kingdom
County: Somerset
Posts: 337
Had an integrale that did the same within 50 metres everyday on the way to work. Was the crank position sensor
javars is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

cutting , gtv , intermittently

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome