ecu/chip - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 02-01-12 Thread Starter
Status: gtv 2.0 twinnie
AO Member
Join Date: Dec 2010
Location: United Kingdom
County: Gloucestershire
Posts: 175

Member car:

gtv ts


Hi guys,
I recieved my new chip for my ecu a few weeks back and have finally got some time to fit it tommorrow,after reading the threads on ecu reset i am unsure weather its makes any difference if the car should be up to temp or done from cold,
so do i disconnect battery and do the job first thing (engine cold)
or go for blast first (engine up to running temp)
cheers guys.

Last edited by alf22; 02-01-12 at 15:39.
alf22 is offline  
Sponsored Links
Status: -
AO Silver Member
JakeC's Avatar
Join Date: Jan 2011
Location: United Kingdom
County: Staffordshire
Posts: 1,428

Member car:

Z4 3.0si

What have you actually brought a new ecu or a chip that needs fitting in the existing ecu?

Either way disconnect the battery before you remove anything. You don't need to do anything else
JakeC is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

ecu or chip

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome