new thermostat fitted today - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 23-12-11 Thread Starter
Status: proud owner of a 159 too now
AO Member
Join Date: Sep 2011
Location: United Kingdom
County: Essex
Posts: 896
Images: 4
new thermostat fitted today

yes fitted my new thermostat today, took me about 4 hours.
couple of tips.
1. ensure you cover the bell housing below the stat to ensure no fluid goes in the clutch
2. don't overtighten the two 13mm bolts that hold it on(its only alloy)
3.the hose clips are a pain in the arse to remove so replace all with jubillee type.
4. good time to renew your anti freeze , but don't mix if its pink use the same.
5. take your time and be carefull when removing rubber pipes you don't want to tear any (i found a narrow bladed flat scewdriver pushed up pipe and spray a little plus gas in gap to start things moving
6.double check for leaks once its all filled take car for short drive visual check. to if necessary when engine cold.

mine for alfa spider phase 2 (916) was 28 from europarts oe equipment included 25% discount promotion code is "25winter" (to get 25% off) there are many posts on here about stats so have a look, cars running better now and at the correct temp 88c. this reduces engine wear and increases mpg too.
my old stat was 20% open at all times so doing nothing to regular the engine temp.
quick way to check your stat.
start cold engine. feel top hose it should NOT BE HOT to start with,
the heater hoses that come off the stat should start warming up first.(thats the narrower 2)
then after approx 5-10 mins when the temps up to 88c the stat should open and the top hose start to feel hot.(if all your hoses feel the same temp after 30 secs which mine did stat is knackered.
phwspider is offline  
Sponsored Links
Status: -
AO Gold Member
badgers_nadgers's Avatar
Join Date: Sep 2003
Location: United Kingdom
County: Dorset
Posts: 7,154

Member car:

156 GTA SW

8. Pay someone else to do it.
badgers_nadgers is offline  
Status: 159 wagon arrived
AO Member
adeb38's Avatar
Join Date: Nov 2011
Location: United Kingdom
County: East Sussex
Posts: 295
what where u doing for 4 hours !!!! done mine in 15 mins .
adeb38 is offline  
Status: Looking for a BMW 330D...
AO Gold Member
Starkers's Avatar
Join Date: Nov 2008
Location: Brighton.
County: Good old Sussex by the sea
Posts: 11,228
Images: 2

Member car:

The train :(

Originally Posted by adeb38 View Post
what where u doing for 4 hours !!!! done mine in 15 mins .
Looks like he was "cleaning the bell housing below the stat as fluid goes in the clutch"...!

15 minutes? You can come and help me with mine then!
Starkers is offline  
(Post Link) post #5 of 6 Old 24-12-11 Thread Starter
Status: proud owner of a 159 too now
AO Member
Join Date: Sep 2011
Location: United Kingdom
County: Essex
Posts: 896
Images: 4
took me longer than that to get the bloody clips off, and filter the anti-freeze. i was not in a rush.
phwspider is offline  
Status: Occasionally driving my Gtv
Club Member
Membro Medio
alexGS's Avatar
Club Member Number: 1265
Join Date: Jul 2007
Location: New Zealand
County: Waikato
Posts: 2,361
Images: 36

Member car:

Gtv V6

Excellent advice and a great job done regardless of how long it took

I find I get most of the way through and then realise I don't have the right size of hose clip, so it's a 45-minute round trip to get some... including a few spares for next time that inevitably get lost...

I've never seen a Twinspark engine that didn't have a stuck-open thermostat. Think I've replaced five now.

alexGS is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

fitted , thermostat , today

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome