sorry but another spider roof problem - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Gold Member
Wezley's Avatar
Join Date: Sep 2011
Location: United Kingdom
County: Greater Manchester
Posts: 11,402
Images: 27

Member car:

159 2.4 JTDm

Originally Posted by brispencer View Post
It's at times like this that I'm glad I've got a manual roof.
...but the rest of the time

So far so good in four years.
(That'll **** that up then )
Wezley is offline  
Sponsored Links
Status: -
Join Date: Nov 2014
Location: New Zealand
County: Auckland
Posts: 1

Member car:

Alfa 916 Spider

Roof problem

I had this problem
It was solved by refilling the oil tank on the pump. very simple but hard to do,like many things Alfa, think outside the box, .
Long length of PVC and long fingers to get to the filler cap.

Whats happening is the trigger arm on the lock nuts are been activated do to the lack of oil in the cylinders.
My Spider has a leaking cylinder and a fill tank lasts about 6 months and i use the roof maybe 4-5 times a week.

Plonker is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

problem , roof , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome