Cold starting - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 19-09-11 Thread Starter
Status: Proud Spider owner
AO Member
Join Date: Feb 2010
Location: United Kingdom
County: Nottinghamshire
Posts: 80
Images: 2
Cold starting


I am the owner of a lovely Alfa Spider 2.0 ltr T/Spark P reg Oct 1996 72,000 miles. I have owned her for 18 months without any faults. I have just started having problems when starting her from cold, She dosn't go into fast idle, if I take my foot of the accelerator pedal she stops. I have to sit with my foot on the pedal for a minute or two, then she runs at about 800 RPM. Once she warms up she runs ok. Any suggestions anyone.


pjowen is offline  
Sponsored Links
Status: 17" Speedline Enzo's
Club Member
Membro Premio
Stixy's Avatar
Club Member Number: 479
Join Date: Oct 2007
Location: United Kingdom
County: Norfolk
Posts: 1,281
Images: 14
Could be a "sticky" Idle Control Valve. Not sure where it's fitted on a twinnie. I'm sure someone will be along and tell you. You could try searching....
Stixy is offline  
Status: -
AO Member
Join Date: Jun 2010
Location: United Kingdom
County: Cornwall
Posts: 81

Member car:


I am in a similar situation too but only have very low(well normal 800) revs from start up(i would imagine that it would be higher until up to temp??) and if you change into second too early it feels like you have bump started it. There is a cold start sensor that could be playing up although i don't know if this moderates fueling while the car is running for a bit before it gets up to temperature or just helps with the initital start up??? Any techies on hand to comment?

Have a look on shop4parts as they sell cold start sensors and i imagine Alternative Autos do.
ShellyGTV is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

cold , starting

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome