What is your sound setup? - Page 3 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Member
Olle D's Avatar
Join Date: Jun 2009
Location: Sweden
County: Uppsala
Posts: 131

Member car:

GTV 3.0 24 v -98

I got an Alpine Ida-X200 head unit and 5,25' JBL GTO component speakers in front and JBL GTO 6,5 coaxial speakers in the back. I built new baffles for the front speaker to seal them properly (I didnít do that for the back). I was very disappointed at first as I had expected a huge difference, but I wasnít impressed. After they now has been installed for two years (i only use the car during the summer) it sounds much much better. Apparently the speakers needed some braking in before they reached their potential. Iím now thinking of putting in an external amp...


Last edited by Olle D; 20-08-11 at 12:36.
Olle D is offline  
Sponsored Links
Status: Dreaming of upgrades
AO Member
cgc's Avatar
Join Date: Jan 2010
Location: United Kingdom
County: Monmouthshire
Posts: 831
Well my 8" pioneer rear install went well and they are producing a lovely rich and full sound, unfortunaly the cheapy alpine ones in the front are getting alot of distortion. I hope the new 13cm pioneer component speakers i have ordered solve this; they do go to a much low frequency range, but still only 35rms so i will just have to see. The proof will be in the listening!
cgc is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

setup , sound

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome