Spider Electric Hood, Leak in hydraulic system - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 04-08-11 Thread Starter
Status: -
duetto's Avatar
Join Date: Jul 2007
Posts: 5
Thumbs Up Spider Electric Hood, Leak in hydraulic system

Hello to all Alfisti, and thanks for a great website with interesting information and topics
I have an Alfa Spider from 1998 with E-hood. This leads to problems if there are leaks in the hydraulic system. At first I thought it was a leaking cylinder, but after this exchange (from Ebay), there is still a leak. The conclusion is now that I have a hose that is leaking. This leads to the following questions:
Is there anyone who have had the luck to find a supplier for these hoses?
Is it necessary to replace repair kit? (O-ring )?
Is there an O-ring between the cylinder and hose, and can they be replaced?
How is it possible to get access to the pump, so that it is possible to sepperate the hose from the pump?

Thank you in advance!

duetto is offline  
Sponsored Links
Status: Sold
AO Member
JAO's Avatar
Join Date: Nov 2010
Location: United Kingdom
County: Derbyshire
Posts: 384
Images: 20
Hi Anders,

I think you will find that it's the seals within the hyraulic rams that are worn and the oil is dripping onto the connectors and the pipes. This is quite common and you are best leaving it alone if you can, just top up the reservoir as and when you need to unless the leak is extremely severe.

I would warn you to be very carefull when trying to disconnect anything as the oil can be very highly presssurised and can be harmful. It may be possible to service the rams but it will be a specialist job or just a replacement for new.


Project Victoria
JAO is offline  
(Post Link) post #3 of 3 Old 04-08-11 Thread Starter
Status: -
duetto's Avatar
Join Date: Jul 2007
Posts: 5
Thanks for the ansver.
The leak is so bad that the system cant build up pressure.
I allready have replaced the hydraulic ram I thought had the leak, but still the same result.
So now I am looking for the hose.

best regards

duetto is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

electric , hood , hydraulic , leak , spider , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome