Temp gauge / possible thermostat issue - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-07-11 Thread Starter
Status: Constantly tinkering
AO Member
tok78's Avatar
Join Date: Feb 2008
Location: United Kingdom
County: Greater London
Posts: 125
Images: 6

Member car:


Temp gauge / possible thermostat issue

I have just picked up a '99 P2 Spider 2.0TS and am working through a list of (smallish) issues.

This post is going to deal with the engine temperature.

After collecting the Spider, I drove her 230 miles back home, during the whole journey the engine temp never reached 90C. It stayed around 70C.

Is this a problem?

On my 145 Cloverleaf (2.0 TS, 2000 model), the engine temp went to 90C and stayed there, same with my 1.8TS GT.

The history says the sending unit was replaced in the last 18 months, but no mention of the thermostat being changed.

What are the implications of not changing the thermostat immediately?
tok78 is offline  
Sponsored Links
Status: -
AO Silver Member
seadart's Avatar
Join Date: Oct 2010
Location: United Kingdom
County: Hampshire
Posts: 2,197
the lower mark is 80c not 70c.. it should sit somewhere between the lower mark and 90c on the move and then rise to 90c in traffic when the fan cuts in. The upper mark is 100c.. phase two stats open at 87c 88c ish.. phase one 83c ish

if it stays below the lower mark on the move then the thermostat may be on its way out.. engine will run cool..
stats are around fifty quid and take thirty mins to change.. easy job..

there are two senders one in the stat for the ecu and one in the block.. (just behind the stat) for the temp guage.

Last edited by seadart; 18-07-11 at 15:42.
seadart is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

gauge , issue , temp , thermostat

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome