GTV 3.0L V6 24V engine wouldn't fire. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 26-06-11 Thread Starter
Status: -
Join Date: Mar 2011
Location: United Kingdom
County: Gloucestershire
Posts: 4

Member car:

GTV 3.0L 24V

GTV 3.0L V6 24V engine wouldn't fire.

Code light wouldn't go out, engine would not fire.

The answer was the ECU power up relay (8.50 from Alfa). There are two located side by side on a relay bank under the plastic cover of the F/O/S wheel. One powers the other which in turn powers up the ECU. An easy check if you have the same problem.

A month later, same problem - this time it was a dodgy connection on the low voltage cable going into the yellow immobiliser module strapped to the steering column under the dash. A good clean up of the 2 plugs and module connections solved this problem.
ISO John is offline  
Sponsored Links
Status: v6 rules
AO Silver Member
gtvtommo's Avatar
Join Date: Apr 2011
Location: United Kingdom
County: West Midlands
Posts: 1,084

Member car:

916 v6 lusso

sounds like the relays were mounted above the os wheel on the outside of the car which if I read you correctly is a daft place for relays as the damp will get in................surely not ?
gtvtommo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

24v , 30l , engine , fire , gtv

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome