Heater switch problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 18-06-11 Thread Starter
Status: Happy happy
AO Member
Judders's Avatar
Join Date: Feb 2010
Location: United Kingdom
County: Cambridgeshire
Posts: 20
Images: 4

Member car:


Heater switch problem

Hi all,

Has anybody had the same problem? If i turn the temperature up or down, it mostly stays the same temperature. If i get in it the next day, it will be stuck on the temperature i left it at and will not adjust. So if i drive one day with the heat on, adjust it to cold before i switch of, then the next time it will be cold and visa versa. When its hot, its roasty toasty hot, and when its cold (with air con on), its ice cold. Could this be a fault switch, or has the fan resistor got anything to do with temperature control ? The fan works on all speeds. Car is a 99 3l.


Last edited by Judders; 18-06-11 at 15:04.
Judders is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

heater , problem , switch

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome