2000 (W) Spider 2.0TS Indicator/Sidelight Fault - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 29-05-11 Thread Starter
Status: -
Join Date: May 2011
Location: United Kingdom
County: -
Posts: 1
2000 (W) Spider 2.0TS Indicator/Sidelight Fault

Hi there - grateful for any advice at all with the following problem with my Spider:

1. The indicators stopped working altogether - checked fuse - it was blown - replaced fuse.
2. Indicators now work but left side ticks rapidly (relay??).
3. Simultaneously, discovered rear pass/side tail light and front dvr/side sidelight are dead - checked bulbs - ok - checked fuse - blown - blows again immediately when replaced.
4. Additionally airbag warning light has come on!!!

HELP! Don't want to get ripped off by an auto spark - does anyone recognise this or can anyone suggest easy fix?!!

Much obliged.
hairdresser_1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

2000 , 20ts , airbag , fault , fuse , indicator or sidelight , indicators , relay , sidelights , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome