Horn problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-05-11 Thread Starter
Status: -
AO Member
TheCurryMonster's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: East Sussex
Posts: 46

Member car:

2.0 P2 GTV Lusso

Horn problem

Bit of a strange problem this...

My GTV likes to play it's own horn. It happens immediately after I've used it and seems to be worse when I go over bumps. It doesn't always do it and it usually has it's fun on and off for a few minutes, which can be a bit embarrassing. Sometimes beeping th ehorn again fixes it and sometimes it makes it worse.

It's always done this since I had the car, but it seems to be getting worse. This morning I went over a big bump and the horn stuck on completly and I hadn't even used it!

Seems like it might be time to fix it.

Anyone know the problem (and the fix)?

I am guessing that it needs new switches fitting - any ideas where I can get one and how to get to it without setting off the airbag or anything else daft?

Or is likely to be a relay or ECU problem or something best left to somebody that knowswhat they are doing?
TheCurryMonster is offline  
Sponsored Links
Status: -
AO Silver Member
.:ian:.'s Avatar
Join Date: Feb 2009
Location: United Kingdom
County: Hampshire
Posts: 1,574

Member car:

GTV twinspark

Might be the relay (I3 20A) but more likely to be the plates in the steering wheel, there are 2 metal plates held apart by springs and when the two connect it grounds the coil on the relay which gives you the horn.....

If you take the cowls off behind the wheel the wire from the relay is blue-white and in the top right hand connector on the stalk unit.
.:ian:. is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

horn , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome