One washer jet no worky - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
One washer jet no worky

Hi all

I have put the eBay wipers, with the jets built into the blades and they have worked a treat. However recently the passenger side jet has stopped working. I recently got a new windscreen fitted and the chap took the wipers off, could he have dislodged anything underneath? Any ideas before I start dismantling?

Many thanks
Sponsored Links
Status: -
AO Silver Member
Join Date: Oct 2005
Location: Northumberland
Posts: 2,139

Member car:

P2 GTV 3.0

Probably a pipe pulled off or a union split under the black plastic panel below the windscreen. If so, water will be spraying out under there whenever you use them so you will see it dripping onto the ground. The panel is just held on with about four screws and some push fittings. Pull it off and have a look. If you have changed to the flat blades, I did that and thought the pipes were long enough but eventually one pulled off - on the wiper arm so clearly visible - so I fitted the extra hoses that had come with the blades.
SimonT is offline  
Status: -
AO Silver Member
seadart's Avatar
Join Date: Oct 2010
Location: United Kingdom
County: Hampshire
Posts: 2,197
I use small cable ties on the pipe unions.. rather like jubilee clips.. one of my pipes kept coming off for some reason..
seadart is offline  
Status: - Update
Posts: n/a
Thanks chaps will check that out, at the moment I cannot see any water pouring out from a disconnected tube, will have to take it apart me thinks
Status: Currently refreshing engine bay
AO Member
Join Date: Sep 2010
Location: United Kingdom
County: Surrey
Posts: 374

Member car:

GTV 3.0 24V

Out of intrest how much did the new screen cost ?
BADfish10 is offline  
Status: Looking for a V6 again
AO Member
TOPKIT's Avatar
Join Date: Sep 2007
Location: United Kingdom
County: Kent
Posts: 491
I just got a new screen for my Spider and exactly the same thing happened the hose for the passenger side had come off. My screen cost me 70.00 as excess through my insurance company.
TOPKIT is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

jet , washer , worky

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome