Rear Deck overide switches - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 15-03-11 Thread Starter
Status: -
AO Member
Rufus Ruffcut's Avatar
Join Date: Sep 2008
Location: United Kingdom
County: Oxfordshire
Posts: 78
Rear Deck overide switches

Hi all,

Rather than hijack some existing threads relating to Spider hood issues I have a question that has been puzzling me.

Why is it that when the rear deck fails to open or close on the switch as part of the normal raise / lowering process will it work when using the overide switch?

If the overide switch only operates the deck release / lock motor exactly the same as the normal process then why doesn't the motor operate in the normal process?

I have had the eternal issue with my rear cover not releasing and tapping the motor sometimes works, I read about the improved gear for the motor so ordered one (I live in Germany and use the car when back in the UK so couldn't examine the gear beforehand) in the hope I could stop beating the c**p out of the deck release motor.

On fitting the new gear the old one that came out had all it's teeth and looked good (albeit a little too pink for my liking) so I doubt this has fixed my problem.

So should I start worrying about things like roof ecu's etc?

If anyone can shed some light on this I would be most grateful



Rufus Ruffcut
Growing old is obligitory, growing up is optional
Rufus Ruffcut is offline  
Sponsored Links
Status: pretty good actually...!
AO Member
Cibo's Avatar
Join Date: May 2007
Location: Ireland
Posts: 695

Member car:

916 Spider

I'm not an expert and to date have had no trouble with my hood, but from what I understand the switch just releases the lock that grips the pins, the rest is done by a hydraulic system....?

Using the switches just bypasses the hydraulic system and you don't feel any resistance as the system is not 'powered up'...?

I'm sure someone much more knowledgeable will be along in a minute.....!
Cibo is offline  
(Post Link) post #3 of 3 Old 17-03-11 Thread Starter
Status: -
AO Member
Rufus Ruffcut's Avatar
Join Date: Sep 2008
Location: United Kingdom
County: Oxfordshire
Posts: 78
hi Cibo,

Thanks for the response, so if my hydraulic oil level was low (which I believe it is as the roof is lazy o open / close) that this could also cause the switch problem due to low pressure?

She is getting a full service plus other bits in a few weeks so have asked them to check and fill the roof reservoir.

Fingers crossed

Rufus Ruffcut is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

deck , overide , rear , switches

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome