Just bought a GTV V6 - some issues have come up! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 12-03-11 Thread Starter
Status: Thoroughly enjoying Alfa Ownership :)
AO Member
radicalmachine's Avatar
Join Date: Mar 2011
Location: United Kingdom
County: East Sussex
Posts: 735
Thumbs Up Just bought a GTV V6 - some issues have come up!

Hi everyone,

I've just bought a T-reg GTV V6 - done 74000 miles, FSH, etc etc. I took the car for a test drive and didn't notice anything out of the ordinary. The car is due a cambelt service shortly.

On purchasing the car, I drove 100 miles back home, and had no problems. Engine pulling as it should. However, I parked up for about half an hour, and went to drive again, and the engine has started hesitating (had been warmed up). If I throttle gently all through the RPM range there's only a touch of hesitation, but if I plant it, it hesitates at about 4000-4500 and stops pulling as hard.

I stopped the car, for fifteen minutes, got back in to drive, and suddenly the issue disappeared - back to normal. Then, this evening, had it sitting for about 5 hours, drove again, and same problem.

I'm getting it serviced this coming week, but can anyone let me know what I might be in for here?

Many Thanks ,
radicalmachine is offline  
Sponsored Links
Status: Looking for a V6 again
AO Member
TOPKIT's Avatar
Join Date: Sep 2007
Location: United Kingdom
County: Kent
Posts: 491
Hi and a big welcome to the forum. Do you get any lights showing on the dash in particular one that looks like an injector, It could be the Maf (air flow meter) As you have only just got it i would give it a good service first, if you are getting the cambelt changed then i would have a new set of plugs at the same time, along with your all important oil and air filter. Does it get up to temp ok. The only other thing that i can think of is maybe a dodgy coil pack. If you are getting it serviced or you know someone that has either Alfadiag or Fiatscan you could get it diagnosed as the fault may show when it is plugged in.
TOPKIT is offline  
Status: profesional ledgend
AO Silver Member
bradpit999's Avatar
Join Date: Oct 2010
Location: United Kingdom
County: West Midlands
Posts: 2,280
Images: 42
if its not to cheeky mind sharing how much you paid for it,

sounds very much like MAF to me as its the 4000-4500 rpm thing that lets me think it is, that and the fact its intermitant, deffinatly get the plugs done at the same time as you have to take the plenum chamber of to get to the back ones
bradpit999 is offline  
Status: OEM'd my rear
AO Silver Member
Freds GTV 2001's Avatar
Join Date: Dec 2008
Location: Australia
County: New South Wales
Posts: 5,223
Images: 48
MAF - 99% Sure

Happens to all GTVs round that mileage.

Dont spend Big $$$ Diagnosing the problem - its 99% Certainty its a MAF
Freds GTV 2001 is offline  
Status: Chillin
AO Silver Member
Chocoboy's Avatar
Join Date: Dec 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 5,621
Images: 13

Member car:

2005 147 JTD

agreed with all the above MAF. or much less likely but a possiblity get it on diagnostics and see if there are an error codes relating to the lambda, when mine went it was a combination of duff MAF and Lambda Sensors
Chocoboy is offline  
(Post Link) post #6 of 6 Old 13-03-11 Thread Starter
Status: Thoroughly enjoying Alfa Ownership :)
AO Member
radicalmachine's Avatar
Join Date: Mar 2011
Location: United Kingdom
County: East Sussex
Posts: 735
Thumbs Up

Thanks for the welcome

The car gets up to temperature after about 2-3 mins of gentle pooling about, and there aren't any lights up on the dash (so far ha!) thanks for the advice, I'll take her in with that in mind! I'm not super mechanically literate, but a keen learner - what does the MAF do? And what can I expect to pay minus labour?

I paid £2450 after getting him down from £3000. I have a friend who's dad used to buy and sell alfas and he can get me discounted servicing which will save me big dollar!

The bodywork is practically mint as is the interior. Has slight wear on the near side rear tyre and I'm told this might indicate suspension bushes need replacing - I factored all these things into the price I paid and I believe I've got a good deal!

radicalmachine is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

bought , gtv , issues

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome