Stereo still sounds terrible, help please! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 03-03-11 Thread Starter
Status: Down to two :-(
AO Silver Member
SimonGTV's Avatar
Join Date: Jul 2006
Location: Sheffield
Posts: 1,651
Stereo still sounds terrible, help please!

I didn't have the code for the factory stereo so i bought a new Pioneer unit and reading how bad the alfa speakers were i bought some alpine replacements too.

When i came to fit the speakers though i see they've already been replaced with decent JBL speakers front and back using the proper adapters but the sound is still terrible.

Difficult to describe and forgive my lack of acoustic knowledege but the sound is tinny, rattley and generally poor.

Any ideas what it could be, do the doors need some sort of baffle, am i missing another 'alfa fix'


Current cars - 1974 Spider 2000, 1978 Alfetta GTV.

Gone but not forgotten - 1999 GTV TS, 1987 Alfetta GTV, 1968 Giulia Super 1600, 1967 GT Junior 1300.
SimonGTV is online now  
Sponsored Links
Status: -
AO Silver Member
.:ian:.'s Avatar
Join Date: Feb 2009
Location: United Kingdom
County: Hampshire
Posts: 1,574

Member car:

GTV twinspark

Check the polarity is the same on each speaker, the colour scheme is, uh, very Italian.
Speaker LH front - red/black(+) & white/black(-)
Speaker RH front - pink/black(+) & purple/black(-)

Speaker LH rear - orange(+) & orange/white(-)
Speaker RH rear - light blue(+) & light blue/black(-)

If one speaker is out of phase with the other you will lose a lot of bass.
.:ian:. is offline  
(Post Link) post #3 of 6 Old 03-03-11 Thread Starter
Status: Down to two :-(
AO Silver Member
SimonGTV's Avatar
Join Date: Jul 2006
Location: Sheffield
Posts: 1,651
thanks, i'll check but it looked like the speakers were a straight swap with no change to wiring
SimonGTV is online now  
Status: -
AO Member
ōyvind I's Avatar
Join Date: Mar 2010
Location: Norway
County: Akershus
Posts: 31
Hi, I've experienced the same. Changed the head unit to a Becker Grand Prix, Canton RS130 front and CX160 at the rear, both coupled to an Audison SX4 amp, hence cost is not bargian.
The sound is however rather thin.
Very god uper mid-range and lots of sparkle.
The lover mid range and bass is on the other hand not dominating to put it mild.
I did not assemble this my selv (due to time) but notice that around the adaptors put in at the front there is rather much air between them and the door "card", which generally is not a good idea to get bass.

Anyone expereienced the same?


ōyvind I is offline  
Status: -
AO Member
Olle D's Avatar
Join Date: Jun 2009
Location: Sweden
County: Uppsala
Posts: 131

Member car:

GTV 3.0 24 v -98

Well, I changed my head unit to a Alpine IDA-X (something) with decent JBL 5.25' component speakers in front and JBL 6.5' rear. I also soudproofed the doors and build air tight baffles for the speakers. The re**** is still disappointing and I'm not sure what to do next. I'm thinking perhaps getting a decent amp for the speakers....

Olle D is offline  
Status: -
AO Member
Join Date: Jan 2010
Location: United Kingdom
County: West Midlands
Posts: 53

Member car:

alfa 1.9 gtdm

i would definately recommend an alpine. you can buy an m;bus cable for around 15 pounds this allows you to plug your ipod nano to it (cristal clear sound unlike the fm transmitter),which ive done. a sub in the boot is the only way in my book. speakers in the doors are fine for midrange. ive got the alfa gt...
jeffry011 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

sounds , stereo , terrible

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome