Hesitant when cold - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: Chillin
AO Silver Member
Chocoboy's Avatar
Join Date: Dec 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 5,621
Images: 13

Member car:

2005 147 JTD

Originally Posted by msgtv View Post
Was hoping that wouldnt get mentioned, i'm touchy about it......ok probably done that to death now
sorry matey
Chocoboy is offline  
Sponsored Links
Status: -
Join Date: Feb 2012
Location: Australia
County: South Australia
Posts: 3

Member car:

1998 GTV V6

Similar Experience - Hesistation


I had a very similar symptom recently with my Phase 1 V6 GTV. Hesitated when cold, slightly lumpy idle and my fuel injection light was on. Took it to the garage..... no quick fix available so I took it back.

The problem ended up being a faulty relay under the RHS cover panel in the engine bay. The relay was triggered by the fuel pump relay and is responcible for supplying power to the air flow sensor. When I tested the plug at the AFM, I didn't have any power. One of the pins should have 12v with the ignition on.

Anyway... replaced the relay, now had power at the AFM. Reassembled air intake, started engine and presto... smooth idle, hesitation when cold gone, check fuel injection light gone (it cleared itself within seconds of starting the engine).

Cheers Matt
matthewlongauto is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

cold , hesitant

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome