Boot lock not working? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-02-11 Thread Starter
Status: Do you even know how to V6?...
AO Gold Member
Ian Lusso's Avatar
Join Date: Sep 2007
Location: South Africa
County: Western Cape
Posts: 10,755
Images: 43
Boot lock not working?

Hi, yesterday suddenly I noticed my boot lock wasn't working? i turn the key and it just rotates but the boot doesn't unlock? How do I fix this?
Ian Lusso is offline  
Sponsored Links
Status: Constantly Nagging Lincolnshire Members !
Regional Support
For Lincolnshire - AOL
Nige005's Avatar
Join Date: Jan 2008
Location: Boston, Lincs
Posts: 16,082
Images: 22
Looks like the Lock will have to come off to investigate.

I have to remove mine sometime soon to sort out the " Boot Open " light on the Dash, if you haven't sorted it by then I'll look and try to see how it works.
Nige005 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

boot , lock , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome