Pipercross coldair filter eats another MAF. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 02-02-11 Thread Starter
Status: -
Join Date: Jun 2010
Location: United Kingdom
County: Midlands
Posts: 334

Member car:


Pipercross coldair filter eats another MAF.

Another MAF dead, so dead it knocked my car out totally again. Accelerate then no power roll to stop get out disconnect MAF, car starts drive home, bit lumpy but still runs well but notice not as good as with MAF connected before she died (she runs really really really well normally).

So new MAF and maybe time to get rid of the pipercross, unless maybe something else is at fault?

BTW 3.0 V6 MAF's on ebay for 170 quid? any good?
geeteevee1999 is offline  
Sponsored Links
Status: Rombo di tuono
Club Member
Membro Premio
Dawsub's Avatar
Club Member Number: 412
Join Date: Mar 2007
Location: United Kingdom
County: East Ayrshire
Posts: 2,197
Images: 15
Get a BMC CDA , no Maf problems with them . Cone filters are the deathknell for the Maf on a V6 . Get a Bosch Maf to be on the safe side , Cheap Mafs on ebay are always too good to be true
Dawsub is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

coldair , eats , filter , maf , pipercross

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome