Intermitant headlight - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Intermitant headlight

hi all, the problems have started already!! Headlamp blew on Sunday, no dramas replaced with new one. Plugged it in and worked.

Next day it didn't! nothing. Then later on in journey it worked again! Guessing a duff connection somewhere, anyone got any experience of this?

Thanks in advance

Sponsored Links
Status: Mangia bene, vivi felice
AO Silver Member
gtv73's Avatar
Join Date: Jan 2011
Location: United Kingdom
County: Norfolk
Posts: 1,300
Hello Gino,

Before you go and get another bulb, take you headlight unit off and make sure all the electrical connections are secure and looking right with nothing damaged or broken. (includes the headlight unit as this recent weather is damp and 'orrible'). Then just follow with your index finger the main wire to check for any damage or fraying, then check your fuse's and make sure you have got the right fuse in place and I know it sounds really silly but make sure you got the right bulb for your headlight.

Easy to do and only take about ten mins to do.

Drive it like you stole it...
gtv73 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

headlight , intermitant

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome