roof problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 30-01-11 Thread Starter
Status: -
AO Member
Join Date: Aug 2008
Location: United Kingdom
County: Warwickshire
Posts: 41

Member car:

2001 cup

roof problem

Hello my spider`s roof had a fault it would go through the sequence until it got to raising the roof cover then it would stop.I removed the motor that powers the cover and had it tested it has power going to it and from it,but since plugging it back in absolutely nothing works! any ideas on the original problem and the developed problem? any suggestions gratefully recieved.
graham long is offline  
Sponsored Links
Status: -
AO Member
johnnyboy71's Avatar
Join Date: Jul 2009
Location: United Kingdom
County: Lancashire
Posts: 464

Member car:

'98 Spider

Graham, when the roof cover is due to go up, can you hear the motor moving? If not try tapping the gear mechanism with a hammer!! (round bit at the end of the motor) May well be the cogs worn.
johnnyboy71 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

problem , roof

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome