Success airbag light fixed on my phase 1 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Success airbag light fixed on my phase 1

Hi to all.
Just to give those of you with the airbag light on a glimmer of hope i set myself the task of getting rid of that damn light this evening.
I have been thru all the under the seat and pretensioner routine to no avail so i attacked it a different way this evening.
I have been getting a defective ecu and low battery voltage code.
After some investigation it becomes apparent that the live wire that feeds the airbag ecu which is served by the services fuse has another fuse that it goes thru before it goes to the ecu it is mounted just behind the round cross bar you see when you have removed the fuse panel.
You can just see the ten amp red fuse pointing downward covered by a black plastic cage the fuse holder is also red you can tell its the correct one as it has a blue with a red tracer on one of the rear exits of the holder.
The fuse was caked in dust and muck so have contact cleaned it and put some contra lube from maplins on it and put a spanking new fuse in and replaced back on rail.
Then while the battery was diconnected thought i would clean all the connectors on the steering column the same way. Ignition barrel connectors awkward to get at but they got the same treatment.
Reconnected the battery deleted the codes with my Sykes ACR4 and bingo the codes have not repeated themselves.
Kept starting the car to even entice it back as sick as it seems but just didnt wanted to make a point to myself.
Really hope this helps someone else out.
Persist and ye shall find ??????
Sponsored Links
Status: -
AO Member
Colo's Avatar
Join Date: Jan 2010
Location: Spain
County: Alicante
Posts: 272
Images: 6

Member car:

GTV 3.0 V6 24v

Congratulations!! Now you can say you saw the light (go off)

I´ll be trying that soon, thank you mate!
Colo is offline  
Status: -
AO Member
Join Date: Aug 2009
Location: Australia
County: New South Wales
Posts: 22

Member car:

GTV 916

Hi Reveds1969,

I ahve a phase 1 GTV 2L TS fitted with TRW airbag ecu but I'm having trouble accessing software to connect to the ecu.

What cable setup did you use and what diagnostic software? Where did you get the software from?

AlfaFiatpug is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

airbag , fixed , light , phase , success

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome