hids - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 08-12-10 Thread Starter
Status: -
AO Member
Join Date: Jan 2002
Posts: 224

I've got the hids4u kit on my gtv and the light does'nt look any brighter than the originals. I have only started to use the gtv a lot lately due to my daily commuter car which was crashed last week in the snow and havin driven te gtv in the dark can't believe how bad the lights are. When i turn on the lights the lights go very bright very quickly and then settle down to what i would say normal bad gtv lights. The lenses are clean and dry. Is there something wrong with this kit? Are the ballasts knackered? The kit is about 4 years old.
Any help would be appreicated.

chimo is offline  
Sponsored Links
Status: Alfa V6 - the bestsounding V6
AO Member
markymarkspider's Avatar
Join Date: Sep 2009
Location: United Kingdom
County: Vale of Glamorgan
Posts: 602
Images: 22
I had my HID's fitted about seven or eight years ago and frankly they are still so much better than any normal bulbs. Mine do brighten blue when first switched on, then settle down to a nice bright white with purple extremities.

There must be a problem if you perceive there is no real imporvement.
markymarkspider is offline  
Status: -
AO Silver Member
Davemackenzie's Avatar
Join Date: May 2010
Location: United Kingdom
County: Hampshire
Posts: 1,047
Sounds like knackered bulbs, the ballasts are bullet proof but the bulbs can fail rapidly if there's a fault, contact the manufacturer if it's still in warranty
Davemackenzie is offline  
Status: HIDs Kick Ass
AO Member
Dansolo's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Shropshire
Posts: 889
Images: 26
Stick the old bulbs if in doubt to see how bad the Halogen are , what i have read is that they should be good for 5 years of use (2500 hours ) and will start to change clour as they get older so may be time for new bulbs , as Davemackenzie says the Ballasts are bullet proof if there was a problem with these the bulbs would'nt fire up at all .
Dansolo is offline  
(Post Link) post #5 of 5 Old 09-12-10 Thread Starter
Status: -
AO Member
Join Date: Jan 2002
Posts: 224

Thanks for the replys. I have emailed hids4u and just waiting to hear back from them.
chimo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome