GTV 3.0 Strut Brace / Bonnet issue - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 21-11-10 Thread Starter
Status: -
AO Member
Join Date: Dec 2006
Posts: 23

Member car:

GTV 3.0 v6

GTV 3.0 Strut Brace / Bonnet issue

I have recently fitted a Weichers steel strut brace to my phase 2 v6 GTV. The bonnet no longer shuts properly. It does close and fasten, but it doesn't sit quite right. Has anyone been able to resolve this problem?

Also the open bonnet warning light is now illuminated in the dash.

Any ideas?
ljgand is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Oct 2005
Location: Northumberland
Posts: 2,139

Member car:

P2 GTV 3.0

Much discussed problem - a search should find you some answers. Some types of brace require some minor mods.
SimonT is offline  
Status: -
AO Member
MelbGTV's Avatar
Join Date: Oct 2009
Location: Australia
County: Victoria
Posts: 141

Member car:


Common problem with the Wiechers. I had the same issue with the Wiechers aluminium and ended up ditching it in favor of an OMP.
MelbGTV is offline  
Status: Waxing.
AO Silver Member
misterchase's Avatar
Join Date: Oct 2009
Location: United Kingdom
County: Hertfordshire
Posts: 1,600
Images: 19
I have the wiechers and first fit I had the bonnet open warning, although fit of bonnet not bad as I had previoulsy adjusted bumper to its full travel.

In order to turn off warnign light you need to adjust passenger side bonnet plunger thingy by way of screwdriver stuck in the slot in centre of the spring.

be carefull though as the I adjusted too far and then bonnet wouldn't open, slight panic ensued. All sorted now though

misterchase is offline  
(Post Link) post #5 of 6 Old 22-11-10 Thread Starter
Status: -
AO Member
Join Date: Dec 2006
Posts: 23

Member car:

GTV 3.0 v6

Cheers MC, I'll do that in the day light this week.

SimonT, I have scoured the forums and there is not actually a proper solution that I can find. I PM'd a few of the guys and none of them could help. Maybe I have missed a thread that you have seen?

ljgand is offline  
Status: Please look after this possum
Regional Support North
Is there a meet near you?
Gaz's Avatar
Join Date: Jun 2008
Location: Behind the wheel
County: Lancashire
Posts: 62,404
i have this with a sparco brace. bonnet shuts ok but the rear edge is pushed upwards by the brace. doesnt bother me
Gaz is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

bonnet , brace , gtv , issue , strut

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome