windscreen wipers - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 21-11-10 Thread Starter
Status: -
AO Member
Join Date: Oct 2002
Location: Washington Tyne & Wear
Posts: 75
windscreen wipers

my windscreen wipers only work on intermitant and wash but nothing happens if i want them on constant do you think its a problem with the wiper stalk or something else its a 1996 spider
cheers mick
Mick is offline  
Sponsored Links
Status: -
AO Member
Join Date: Dec 2006
Posts: 23

Member car:

GTV 3.0 v6

You might find a few similar posts on here if you do some searches. My wipers worked every now and again, then not very often, then not at all. For me it was a loose connection in the wiper circuit board
ljgand is offline  
Status: -
AO Member
Join Date: Nov 2009
Location: United Kingdom
County: Highlands
Posts: 116
Images: 1
I know this sounds daft but my wipers used to "catch" and stop on every setting sometimes. I changed the blades and I haven't had any bother since.
Alfa Scozzesi is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

windscreen , wipers

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome