Clutch just went, any ideas? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 16-11-10 Thread Starter
Status: Down to two :-(
AO Silver Member
SimonGTV's Avatar
Join Date: Jul 2006
Location: Sheffield
Posts: 1,651
Clutch just went, any ideas?

Got in the car yesterday and couldn't engage any gear at all.

The pedal moves up and down freely as normal, there doesn't seem to be any loss of pressure and the resevoir is still full so i know it's not the slave cylinder, i relpaced that a couple of years ago anyway.

There has been no clues earlier on, no noise, no grating, it was fine yesterday when i parked it on the drive as normal.

If you engage a gear and then start it up it seems ok and will drive in that gear, ie doesn't try to kangeroo forward like i'd expect

I got a tow to the garage but they can't look at it until thursday so thought i'd get a heads up an here if possible?



Current cars - 1974 Spider 2000, 1978 Alfetta GTV.

Gone but not forgotten - 1999 GTV TS, 1987 Alfetta GTV, 1968 Giulia Super 1600, 1967 GT Junior 1300.
SimonGTV is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

clutch , ideas

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome