Flashing Radio Display - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 25-08-10 Thread Starter
Status: -
inkangel's Avatar
Join Date: Aug 2010
Location: United Kingdom
County: Durham
Posts: 9

Member car:

Spider 2.0L TS

Flashing Radio Display

Hi Guys,

well, I have my first prob that I hope you can help me with.

BTW - I have a 916 Spider TS on a '96 plate

I tried to light a ciggie using the cigarette lighter in the car when I had the roof down and couldn't use a 'normal' lighter. Ciggie lighter wouldn't work and my radio (original factory fitted) died!! I just thought it was typical Alfa electrics and assumed I would be changing a fuse somewhere.

Got to work and thought I would worry about it later, then at lunchtime when I went to check the handbook, it said that all I needed to do was switch the radio back on and input my code.
No prob

Or so I thought.......

Radio display is flashing 'CODE IN', and when I try to input my radio code, it won't let me.
The handbook says that CODE IN should be displayed, but doen't say anything about it flashingand that it should be a simple case of pushing the number buttons and my code should appear in the display as I input it, but it's not happening. Have tried pressing the BND button in case there was a problem there, but still nothing.

Has anyone had the same prob?

inkangel is offline  
Sponsored Links
Status: -
AO Member
Clacton Col's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Essex
Posts: 91
Images: 6
Try removing the face of the radio (the key pad section), clean up the brass terminals on the back of the keypad and in the radio housing (be careful when doing this) replace the keypad- make sure it connects firmly with the body and try again.

I cleaned the brass terminals with a rubber on the end of a pencil - seemed to work. - Good luck!!
Clacton Col is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

display , flashing , radio

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome