Chipped GTV ECU is fried!! - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Member
tylerbohdi's Avatar
Join Date: Mar 2010
Location: United Kingdom
County: South Lanarkshire
Posts: 16

Member car:

GTV 2.0 TS Lusso

Disconnect the battery for at least 45 mins
Reconnect and start the engine but do not touch the throttle and let the car idle for 15 mins.
Turn the car off and leave for 10 mins.
Start the car and take her for a blast.
tylerbohdi is offline  
Sponsored Links
Status: 17" Speedline Enzo's
Club Member
Membro Premio
Stixy's Avatar
Club Member Number: 479
Join Date: Oct 2007
Location: United Kingdom
County: Norfolk
Posts: 1,281
Images: 14
As Tylerbohdi correctly says - Here is the full procedure - Engine ECU Reset (Replaced the MAF, how long for the ECU to re-learn?)
Stixy is offline  
Status: -
AO Silver Member
Join Date: Mar 2008
Location: United Kingdom
County: Wrexham
Posts: 2,844
Images: 6

Member car:

GTA Shed wagon

reset will only work if you can start the car.
Try the air flow meter, failing that get it to a specialist.
(have you checked the cam belt.....)
rmaxeman is offline  
Status: Do you even know how to V6?...
AO Gold Member
Ian Lusso's Avatar
Join Date: Sep 2007
Location: South Africa
County: Western Cape
Posts: 10,781
Images: 43
The simplest to check it the airflow meter. Pull the plug and it should start if the Maf's stuffed. Failing that, the best bet is to get the ecu interrogated for fault codes. The fact that the ecu light is on, means that the ecu knows what the fault is!

Cheers, hope you get it sorted!
Ian Lusso is offline  
Status: -
AO Member
Join Date: Jul 2007
Location: United Kingdom
County: Greater London
Posts: 10
Its definitely the MAF if the injector light is on, common fault on most Alfas!
Akeme is offline  
Status: -
AO Member
ollie2's Avatar
Join Date: May 2008
Location: United Kingdom
County: Edinburgh
Posts: 77

Member car:

GTV 3.0 Lusso

Oh dear...I have noticed my gtv 2.0 has started pinking since I fed it the new Shell save a litre fuel. Have always used Shell as it is the nearest garage (did avoid them for awhile after their dirty work in Nigeria) but could be something in it.
Must investigate. Have owned the car for 5 years, full service and has never pinked ever...
ollie2 is offline  
Status: Constantly Nagging Lincolnshire Members !
Regional Support
For Lincolnshire - AOL
Nige005's Avatar
Join Date: Jan 2008
Location: Boston, Lincs
Posts: 16,083
Images: 22
Originally Posted by Akeme View Post
Its definitely the MAF if the injector light is on,
Sadly this is NOT always the case, life would be so much simpler if it were.
Nige005 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

chipped , ecu , fried , gtv

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome