electrical relays spider s4 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 23-08-10 Thread Starter
Status: -
Join Date: Aug 2010
Location: Ireland
County: Dublin
Posts: 1

Member car:

spider s4

electrical relays spider s4

Spider S4 electrical Problems
My trafficators and electrical windows are not working and at present on a long holiday in south of france with bad french,anybody confirm the relay is the problem
Dick W is offline  
Sponsored Links
Status: 17" Speedline Enzo's
Club Member
Membro Premio
Stixy's Avatar
Club Member Number: 479
Join Date: Oct 2007
Location: United Kingdom
County: Norfolk
Posts: 1,281
Images: 14
What year is your car?

Sent from my iPhone using Tapatalk
Stixy is offline  
Status: Constantly Nagging Lincolnshire Members !
Regional Support
For Lincolnshire - AOL
Nige005's Avatar
Join Date: Jan 2008
Location: Boston, Lincs
Posts: 16,082
Images: 22
Not a Spider Owner so can't help.

However you'll get more response if you Post this in the " Classics " Lounge here. Good luck.

The Classic Alfa Romeos - Alfa Romeo Forum
Nige005 is offline  
Status: tucked up in garage
AO Member
renone's Avatar
Join Date: Jun 2006
Location: Surrey England
Posts: 548
Images: 3

Member car:

Spider S4

The direction indicators & Hazards are on a totally separate relay from the electric windows. Suggest that you check the fuses ( also separate). Looking at the fuse box the power window fuse is the FIRST on the LEFT and should be rated at 25amp. The direction indicators & Hazards are on the FIFTH fuse from the LEFT and should be rated at 10 amp. Power window relay is on the top row SECOND in from the right and the direction indicators and hazards relay is on the row below on the far RIGHT. After checking the fuses are ok and seated properly I would check that the relays are also seated properly. Could have been jarred over a bump??? Also make sure you have not got water ingress into the fuse box.
renone is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

electrical , relays , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome